User Tools

Site Tools


apt-hold

Prevent tool to be updated by apt

There could be known issues with one of the package where the appreciated private setup does not comply to the requirements of the newest version of a package. This could e.g. be 'chromium-browser', where suddenply some deprecitaed function will not work anymore, so it's preferred to stick to the currently installed version.

Mark a package to be on-hold, so this will be skipped with e.g. every 'sudo apt upgrade' run by entering e.g.:

sudo apt-mark hold chromium-browser

Undo the blocking (or holding) by simply unhold the package again:

sudo apt-mark unhold chromium-browser
apt-hold.txt · Last modified: 02.07.2018 15:07 by andreas